Eifric

Lagging w/ high graphic settings

Recommended Posts

Hello! I'm a returning player and I played GC Madness before I think that was before the new client and pet glyphs stuff. Anyway does anyone know how to fix lagging here? I usually played at 4th bar graphics setting in the options before but now it lags the dungeons. Now it only runs smooth when at 1st bar graphics (no background and HP bars) which sucks!!!!!!!

Share this post


Link to post
Share on other sites

You're playing on Windows 10 aren't you?

Yeah...Microsoft changed Direct X9 and now the game isn't compatible with Windows 10 on the latest updates...

Share this post


Link to post
Share on other sites

Hi, what's up?

  I've a friend that he played GC a while ago using Windows 10, and had no problem even if he updated his machine. I advise you to check your computer's drivers, download DirectX 9 and .NET Framework version 4.5 or higher, and Microsoft Visual C ++ 2005 Redistributable Packages until 2017 (If I'm not mistaken). If it doesn't work, try to delay the Windows update to 1803, create a restore point, and then upgrade to the latest version for testing, then if it does not pick up again, stay in 1803.

Thanks for your attention ^-^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now